Not possible to download Microsoft 365 apps from office.com
Minor incident
IT SERVICES
2024-11-15 09:52 CET
· 4 hours, 35 minutes
Updates
Resolved
November 15, 2024 · 14:25 CET
Microsoft have resolved the issues, and Microsoft 365 app downloads are now working again.
Issue
November 15, 2024 · 09:52 CET
Microsoft are having issues with some of their webpages. This is affecting our ability to download Microsoft 365 apps at the moment.
← Back