E-mail issues
Major incident
IT SERVICES
2025-02-07 10:53 CET
· 2 days, 23 hours, 8 minutes
Updates
Resolved
February 10, 2025 · 09:01 CET
E-mail service works as intended again. E-mail that was put in que has now been delivered, but there was a long delay.
Issue
February 7, 2025 · 10:53 CET
There is an issue with our e-mail service and connected functions affecting some of our students and employees. Scan to mail, and some mail list functions are currently not working.
← Back