Valgweb is temporarily unavailable

Minor incident IT SERVICES
2025-02-11 08:28 CET · 1 hour, 26 minutes

Updates

Resolved

The issue has been resolved, and the service is working as intended again.

February 11, 2025 · 09:54 CET
Issue

Students are experiencing service failures with Valgweb at the moment. The IT-department is working on resolving the issue and we recommend that new elections are postponed for a day or two.

February 11, 2025 · 08:28 CET

← Back