NTNU Help out of service

Minor incident IT SERVICES
2025-03-04 10:42 CET · 1 day, 3 hours, 55 minutes

Updates

Resolved

It’s been reported that the service works as intended for everyone now.

March 5, 2025 · 14:36 CET
Issue

The NTNU Help service supplier is currently experiencing issues with the service and this means it is currently out of order for NTNU.

Updated status from the service supplier can be found here. Status TopDesk

March 4, 2025 · 10:42 CET

← Back