NTNU Open is unavailable

Minor incident IT SERVICES
2025-03-18 12:04 CET · 19 hours, 59 minutes

Updates

Resolved

NTNU Open is available again.

March 19, 2025 · 08:03 CET
Issue

NTNU Open is unavailable. We have informed the service supplier.

March 18, 2025 · 12:04 CET

← Back