FS is slow or freezes

Major incident ADMINISTRATIVE SERVICES
2025-06-18 11:06 CEST · 3 hours, 50 minutes

Updates

Resolved

The issues have been resolved.

June 18, 2025 · 14:56 CEST
Issue

FS is having issues at the moment and the service provider is looking into it.

Check out updates from the service provider here.

June 18, 2025 · 11:06 CEST

← Back