Oria is currently not working

Minor incident IT SERVICES
2025-06-23 11:02 CEST · 22 hours, 32 minutes

Updates

Resolved

The service provider has resolved the issue.

June 24, 2025 · 09:34 CEST
Issue

There is an issue with Oria and the service supplier has been notified.

June 23, 2025 · 11:02 CEST

← Back