Elements issue

Minor incident IT SERVICES ADMINISTRATIVE SERVICES
2025-06-25 10:30 CEST · 1 week, 23 hours, 27 minutes, 1 second

Updates

Resolved

It’s now possible to log in with the “Use school/work account” button again.

July 3, 2025 · 09:57 CEST
Issue

Some are having problems opening and editing files in Elements at the moment. For some it works after clicking “Yes” on the error message, but not for everyone. The service supplier has been notified.

June 25, 2025 · 10:30 CEST

← Back