The system for reporting dicrepancies is down

Major incident IT SERVICES
2025-07-04 10:27 CEST · 2 days, 22 hours, 3 minutes

Updates

Resolved

The supplier has resolved the matter.

July 7, 2025 · 08:27 CEST
Issue

The system for reporting and handling HSE incident/disrepancy is down. The service supplier has been notified and is working to resolve the issue.

July 4, 2025 · 10:27 CEST

← Back