Campus internet access downtime

Major incident IT SERVICES
2025-07-08 10:27 CEST · 4 minutes

Updates

Resolved

The problem is now resolved, we apologize for any inconvenience caused

July 8, 2025 · 10:31 CEST
Issue

We are currently experiencing downtime on both cabled and wireless internet on campus, this also affects several NTNU services such as innsida.ntnu.no

We’re working on fixing the problem as quickly as possible

July 8, 2025 · 10:27 CEST

← Back