Issues with Adminfarm

Minor incident IT SERVICES ADMINISTRATIVE SERVICES
2025-08-13 13:16 CEST · 1 day, 1 minute

Updates

Resolved

Adminfarm is working as intended again.

August 14, 2025 · 13:16 CEST
Issue

Adminfarm is working slowly at the moment. There is worked planned after work hours to remedy the problem.

August 13, 2025 · 13:16 CEST

← Back