Some delay on the network outside NTNU
Minor incident
IT SERVICES
2025-10-02 14:16 CEST
· 22 hours, 43 minutes
Updates
Resolved
October 3, 2025 · 12:59 CEST
SIKT reports the issue as resolved around 18:00 on the 2nd of October.
Issue
October 2, 2025 · 14:16 CEST
SIKT are reporting issues with the network connection abroad, and this makes using a lot of network services feel slow.
See status updates from SIKT.
← Back
Service status