Printing problems
Minor incident
IT SERVICES
2025-10-17 08:08 CEST
· 1 hour, 35 minutes
Updates
Resolved
October 17, 2025 · 09:43 CEST
The issue has been resolved and printing can be done the regular way again.
Issue
October 17, 2025 · 08:08 CEST
There is an issue with regular printing at the moment. To be able to print something one can use myprint.ntnu.no until the issue has been resolved.
← Back
Service status