Many services are unavailable

Major incident IT SERVICES
2025-10-20 10:11 CEST · 1 day, 3 hours, 2 minutes, 1 second

Updates

Resolved

The Amazon issues have been resolved and authentication with our services are working again.

October 21, 2025 · 13:12 CEST
Issue

It’s not possible to log in to several of our services due to issues with a major online service supplier (Amazon Web Services).

October 20, 2025 · 10:11 CEST

← Back