FS using EduKiosk isn't working

Minor incident ADMINISTRATIVE SERVICES
2025-10-22 08:21 CEST · 3 weeks, 4 days, 7 hours, 2 minutes

Updates

Update

To get access to EduKiosk again you have to create a new shortcut. You must not delete the old one. We will delete it for you as soon as USIT have fixed things on their end.

You can find the information about creating a new shortcut here under the topic “Can’t start application/desktop from shortcut”.

https://www.usit.uio.no/om/usits-kundeweb/edukiosk/brukerdokumentasjon/generell-dokumentasjon/problemer-og-feil.html

Unfortunately the guide is only in Norwegian.

October 24, 2025 · 14:37 CEST
Update

It is possible to log into FS through Fellesstudentsystem while the issue persists.

October 22, 2025 · 10:50 CEST
Issue

FS is unavailable at the moment.
See status updates for updates from the service provider.

October 22, 2025 · 08:21 CEST

← Back