Several IT services are experiencing problems

Major incident IT SERVICES
2025-11-19 12:06 CET · 25 minutes

Updates

Resolved

USIT informs that the problem is now resolved

November 19, 2025 · 12:30 CET
Issue

The University of Oslo’s IT department USIT who delivers a number of IT-services to other universities in Norway is experiencing problems

This affects several services at NTNU, for example gpt.ntnu.no and studentweb

This post will be updated when we know more

November 19, 2025 · 12:06 CET

← Back