Blackboard login issue

Major incident IT SERVICES
2025-11-21 13:23 CET · 5 days, 20 hours, 6 minutes

Updates

Resolved

The issue has been resolved.

November 27, 2025 · 09:29 CET
Issue

We see that many are unable to log in to Blackboard at the moment. The IT-department is working on resolving the issue.

November 21, 2025 · 13:23 CET

← Back