NTNU Help and other services are down
Minor incident
IT SERVICES
2025-12-05 10:02 CET
· 14 minutes
Updates
Resolved
December 5, 2025 · 10:16 CET
CloudFlare has pushed an update and the problem is now resolved
Issue
December 5, 2025 · 10:02 CET
Because of an error at the company CloudFlare, who offers security services (amongst others) for a large part of the world’s websites, NTNU Help is unavailable. You will also experience that a lot of other popular websites will be down until they fix the error
← Back
Service status