Gløshaugen power outage

Major incident IT SERVICES
2025-12-12 12:57 CET · 2 days, 1 hour, 36 minutes

Updates

Resolved

The incident is resolved

December 14, 2025 · 14:33 CET
Issue

The NTNU Property division has notified us that there is a power outage in several buildings on the Gløshaugen plateau. This can also affect your internet access in the area

They are working on fixing this problem as fast as they can

December 12, 2025 · 12:57 CET

← Back