Problems with NTNU's web store

Minor incident IT SERVICES
2026-01-22 16:07 CET · 21 hours, 48 minutes

Updates

Resolved

The issue has been resolved.

January 23, 2026 · 13:56 CET
Issue

We are experiencing problems with NTNU’s web store which make it impossible to purchase IT equipment and similar, we are working on fixing the problem

January 22, 2026 · 16:07 CET

← Back