Service supplier has issues with IT-integrations
Major incident
IT SERVICES
2026-01-28 12:26 CET
· 32 minutes
Updates
Issue
January 28, 2026 · 12:26 CET
One of our service suppliers has issues with integrations, which in turn can affect several of our services to a varying degree.
Updated status: Service status UIO
← Back
Service status