Leganto via Blackboard is not working

Minor incident IT SERVICES
2026-02-03 14:53 CET · 22 hours, 27 minutes

Updates

Resolved

The issue has been resolved.

February 4, 2026 · 13:21 CET
Issue

It’s not possible to use Leganto (digital reading lists) via Blackboard. The service supplier is working on resolving the issue.

February 3, 2026 · 14:53 CET

← Back