NTNU Help search functionality not working

Minor incident IT SERVICES
2026-02-06 08:50 CET · 26 minutes

Updates

Resolved

TopDesk melder om at problemet er løst

February 6, 2026 · 09:16 CET
Issue

We’re experiencing problems with the search functionality in NTNU Hjelp, the system owner is working on fixing the problem

February 6, 2026 · 08:50 CET

← Back