Problems reaching forskning.it.ntnu.no
Minor incident
IT SERVICES
2026-02-18 11:36 CET
· 1 day, 22 hours, 18 minutes
Updates
Resolved
February 20, 2026 · 09:54 CET
Everyone should be able to connect to forskning.it.ntnu.no again.
Issue
February 18, 2026 · 11:36 CET
Some are not able to reach forskning.it.ntnu.no. We are awaiting a change from HEMIT to see the issue resolved.
← Back
Service status