Microsoft issues

Minor incident IT SERVICES
2026-02-24 14:26 CET · 2 weeks, 1 day, 20 hours, 20 minutes

Updates

Resolved

The issue has been resolved.

March 12, 2026 · 10:46 CET
Investigating

The issue has been resolved.

March 12, 2026 · 10:45 CET
Issue

We are currently experiencing issues with certain functionality in Microsoft products. When connected to the NTNU network, you are unable to add new email contacts and you cannot activate Office 365. If you encounter features that are not working in Microsoft products, you can connect via an external network to resolve the issue, for example by using a hotspot on your phone.

February 24, 2026 · 14:26 CET

← Back