Telia is having issues in several parts of Norway

Major incident IT SERVICES
2026-03-10 11:09 CET · 3 hours, 59 minutes

Updates

Resolved

Telia reports the problem has been solved.

March 10, 2026 · 15:08 CET
Issue

It has been reported that Telia is experiencing major telephony issues in parts of Norway, and this is affecting NTNU. NTNU’s support services are impacted, making it difficult to reach, among others, the Orakel Service Desk, AV Support, and the Service Center by phone.

March 10, 2026 · 11:09 CET

← Back