Problem with Student ID - app login

Minor incident IT SERVICES
2026-03-17 12:35 CET · 2 days, 21 hours, 53 minutes

Updates

Resolved

The issue has been resolved.

March 20, 2026 · 10:28 CET
Issue

There is an issue with the login to the Student ID - app at the moment. The service supplier has been informed.

March 17, 2026 · 12:35 CET

← Back