NTNU's website is unavailable

Major incident IT SERVICES
2026-05-06 12:35 CEST · 53 minutes

Updates

Resolved

The issue has been resolved.

May 6, 2026 · 13:28 CEST
Issue

www.ntnu.no and www.ntnu.edu is currently unavailable. The IT-department is investigating the issue.

May 6, 2026 · 12:35 CEST

← Back