Issue downloading Office applications

Minor incident IT SERVICES
2026-05-13 12:59 CEST · 5 days, 52 minutes

Updates

Resolved

The issue has been resolved.

May 18, 2026 · 13:52 CEST
Issue

Some are experiencing issued downloading Office applications. The IT-department is aware of the situation and are investigating.

May 13, 2026 · 12:59 CEST

← Back