Unstable wifi on campus

Minor incident IT SERVICES
2026-07-10 08:59 CEST · 1 hour, 51 minutes

Updates

Resolved

Problemet er nå løst

July 10, 2026 · 10:50 CEST
Issue

Wireless internet on campus is usntable for many users, we’re working on fixing the problem. Please don’t call Oracle Support Services or send in tickets in NTNU Help.

July 10, 2026 · 08:59 CEST

← Back