Service Disruption Affecting Google Services

Minor incident IT SERVICES
2026-07-22 12:26 CEST · 4 days, 22 hours, 50 minutes

Updates

Resolved

The issue seems to have been resolved with the service supplier now.

July 27, 2026 · 11:16 CEST
Issue

Google is currently experiencing technical issues, causing several popular services to be down or unstable.

Known affected services:

  • YouTube: Issues with playing videos.
  • Google Play Store: Issues with downloading or updating apps.
  • Other Google services: May also be impacted.
July 22, 2026 · 12:26 CEST

← Back