RSpace login issues

Minor incident IT SERVICES
2026-08-25 09:13 CEST · 1 hour, 46 minutes

Updates

Resolved

Login works again.

August 25, 2026 · 11:00 CEST
Issue

There are currently login issues with RSpace. The IT-department is working on resolving the problem.

August 25, 2026 · 09:13 CEST

← Back